Get in touch
Back
Maintenance

ISP maintenance

Completed 9 May at 06:00am BST.

f-generation API
Completed

Maintenance completed

Posted 9 May at 06:00am BST.
Started

Message from ISP:

"CityFibre have advised of planned engineering work on the 9th of May between 00:01 and 06:00 with an expected downtime of 30 minutes in this window for your connection. This is patch part of the optical network."

Posted 9 May at 12:00am BST.